

<!DOCTYPE html>
<html dir="ltr" lang="en-US" prefix="og: https://ogp.me/ns#">
<head>
<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="google-site-verification" content="YZHaMIj24fAprCOt1cgTGTGq9Ahx2MsJywoEEsIVRUQ" />

<script data-cfasync="false" src="https://cookie-cdn.cookiepro.com/scripttemplates/otSDKStub.js" type="text/javascript" charset="UTF-8" data-domain-script="51cb34ae-6aa9-4f80-834a-1bf7ceab89ca"></script>
<script data-cfasync="false" type="text/javascript">
function OptanonWrapper() { }
</script>



<script>
		var dataLayer = window.dataLayer || [];
		var BroadcastTitle = '';
		dataLayer.push({
						'CMSId': '252498', 
			'FullSection': 'High School Sports',
			'CanonicalUrl': 'https://tribhssn.triblive.com/upper-st-clair-girls-golf-coach-living-american-dream-after-immigrating-from-philippines/',
			'Headline': 'Upper St. Clair girls golf coach living American dream after immigrating from Philippines',
			'Author': 'Charles Curti',
			'PostType': '', 
			'Server': 'Production', 
			'Domain': 'tribhssn.triblive.com',
			'Day_of_week': 'Wednesday', 
			'Month': 'September',
			'Day': '14',
			'Hour': '07',
			'Year': '2022',
			'Logged': '',
			'User' : ' '
		  });
		</script>

<script src="https://ajax.googleapis.com/ajax/libs/jquery/3.4.1/jquery.min.js"></script>
<script>
 
	jQuery(document).ready(function() {
	  jQuery("frm_button_submit").click(function() {
		//console.log("clicked");
		var button = $(this).attr('class');
		var action;
		var label;
		if(button == "frm_button_submit")
	    {
			ecat = "Community";
			action = "Start";
			label = "Submit Your Story";
		}
		else if(button == "frm_button_submit frm_final_submit")
		{
			ecat = "Community";
			action = "Submit";
			label = "Submit Your Story";
		}
		else
		{
			//nothing
		}
		console.log(action);
		console.log(label);
		
		dataLayer = window.dataLayer || [];
		dataLayer.push({
        'event': 'trackEvent',
        'eventCategory': ecat,
        'eventAction': action,
        'eventLabel': label
		});
		
		//console.log("pushed");
		
	  });
	  
	  // Social Media Sharing on Story Pages
	  jQuery(document).on("click", 'li.heateorSssSharingRound i', function() {
		//console.log("sassy clicked");
		var socialAction = jQuery(this).attr('title');
		var socialLabel = jQuery('h1').text();
		dataLayer = window.dataLayer || [];
		dataLayer.push({
		  'event':'socialShareStory',
		  'eventCategory':'social share',
		  'eventAction':socialAction,
		  'eventLabel': socialLabel
		});
		//console.log("sassy pushed");
	  });
	  
		/* //2. Facebook Comments. Fires once the comment field is interacted with. It does NOT fire on POST.
		var monitor = setInterval(function(){
		   var elem = document.activeElement;
		   if(elem && elem.tagName == 'IFRAME' && elem.title.indexOf("Facebook Social Plugin") > -1){
			 clearInterval(monitor);
			dataLayer = window.dataLayer || [];
			dataLayer.push({
			  'eventCategory':'comment',
			  'eventAction':dataLayer[0].FullSection,
			  'eventLabel':dataLayer[0].Headline,
			  'event':'trackFBFeedback'
			});
		   }
		 }, 100); */
	});    
	</script>

<script>
			(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
			 
			new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
			 
			j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
			 
			'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
			 
			})(window,document,'script','dataLayer','GTM-WF2XNT5');
		</script>

<link rel="stylesheet" href="https://tribhssn.triblive.com/wp-content/themes/hssn/css/bootstrap.min.css">
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Lato:300|Titillium+Web:400,600">
<link rel="stylesheet" href="https://tribhssn.triblive.com/wp-content/themes/hssn/css/font-awesome.min.css">
<script type='text/javascript'>
(function() {
var useSSL = 'https:' == document.location.protocol;
var src = (useSSL ? 'https:' : 'http:') +
'//www.googletagservices.com/tag/js/gpt.js';
document.write('<scr' + 'ipt src="' + src + '"></scr' + 'ipt>');
})();
</script>
<script type='text/javascript'>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</script>
<link rel="stylesheet" type="text/css" href="https://tribhssn.triblive.com/wp-content/themes/hssn/style.css?840508192" />
<link rel="stylesheet" type="text/css" href="https://tribhssn.triblive.com/wp-content/themes/hssn/print.css" />
<meta property="custom meta field" data-sj-field="author" content="Charles Curti" />
<meta name="mesearchType" content="story" />


<title>Upper St. Clair girls golf coach living American dream after immigrating from Philippines | Trib HSSN</title>
<style type="text/css">
					.heateor_sss_button_instagram span.heateor_sss_svg,a.heateor_sss_instagram span.heateor_sss_svg{background:radial-gradient(circle at 30% 107%,#fdf497 0,#fdf497 5%,#fd5949 45%,#d6249f 60%,#285aeb 90%)}
											.heateor_sss_horizontal_sharing .heateor_sss_svg,.heateor_sss_standard_follow_icons_container .heateor_sss_svg{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
					.heateor_sss_horizontal_sharing .heateorSssTCBackground{
				color:#666;
			}
					.heateor_sss_horizontal_sharing span.heateor_sss_svg:hover,.heateor_sss_standard_follow_icons_container span.heateor_sss_svg:hover{
						border-color: transparent;
		}
		.heateor_sss_vertical_sharing span.heateor_sss_svg,.heateor_sss_floating_follow_icons_container span.heateor_sss_svg{
							color: #fff;
						border-width: 0px;
			border-style: solid;
			border-color: transparent;
		}
				.heateor_sss_vertical_sharing .heateorSssTCBackground{
			color:#666;
		}
						.heateor_sss_vertical_sharing span.heateor_sss_svg:hover,.heateor_sss_floating_follow_icons_container span.heateor_sss_svg:hover{
						border-color: transparent;
		}
		@media screen and (max-width:783px) {.heateor_sss_vertical_sharing{display:none!important}}div.heateor_sss_mobile_footer{display:none;}@media screen and (max-width:783px){div.heateor_sss_bottom_sharing .heateorSssTCBackground{background-color:white}div.heateor_sss_bottom_sharing{width:100%!important;left:0!important;}div.heateor_sss_bottom_sharing a{width:11.111111111111% !important;}div.heateor_sss_bottom_sharing .heateor_sss_svg{width: 100% !important;}div.heateor_sss_bottom_sharing div.heateorSssTotalShareCount{font-size:1em!important;line-height:24.5px!important}div.heateor_sss_bottom_sharing div.heateorSssTotalShareText{font-size:.7em!important;line-height:0px!important}div.heateor_sss_mobile_footer{display:block;height:35px;}.heateor_sss_bottom_sharing{padding:0!important;display:block!important;width:auto!important;bottom:-2px!important;top: auto!important;}.heateor_sss_bottom_sharing .heateor_sss_square_count{line-height:inherit;}.heateor_sss_bottom_sharing .heateorSssSharingArrow{display:none;}.heateor_sss_bottom_sharing .heateorSssTCBackground{margin-right:1.1em!important}}		</style>

<meta name="description" content="Tuesday’s weather in the Pittsburgh area brought the first nip of fall to the air. But with the temperature still hovering around 70 degrees at mid-afternoon, few folks were ready to consider the prospect of wearing extra layers of clothing." />
<meta name="robots" content="max-image-preview:large" />
<meta name="keywords" content="upper st. clair,golf,high school golf,high school sports" />
<link rel="canonical" href="https://tribhssn.triblive.com/upper-st-clair-girls-golf-coach-living-american-dream-after-immigrating-from-philippines/" />
<meta name="generator" content="All in One SEO (AIOSEO) 4.2.4 " />
<meta property="og:locale" content="en_US" />
<meta property="og:site_name" content="Trib HSSN" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Upper St. Clair girls golf coach living American dream after immigrating from Philippines | Trib HSSN" />
<meta property="og:description" content="Tuesday’s weather in the Pittsburgh area brought the first nip of fall to the air. But with the temperature still hovering around 70 degrees at mid-afternoon, few folks were ready to consider the prospect of wearing extra layers of clothing." />
<meta property="og:url" content="https://tribhssn.triblive.com/upper-st-clair-girls-golf-coach-living-american-dream-after-immigrating-from-philippines/" />
<meta property="fb:app_id" content="2722713281326946" />
<meta property="og:image" content="https://assets-tribhssn.triblive.com/2022/09/5429106_web1_ptr-USCGgolf-091422.jpg" />
<meta property="og:image:secure_url" content="https://assets-tribhssn.triblive.com/2022/09/5429106_web1_ptr-USCGgolf-091422.jpg" />
<meta property="og:image:width" content="640" />
<meta property="og:image:height" content="455" />
<meta property="article:tag" content="upper st. clair" />
<meta property="article:tag" content="golf" />
<meta property="article:tag" content="high school golf" />
<meta property="article:tag" content="high school sports" />
<meta property="article:published_time" content="2022-09-15T03:01:50+00:00" />
<meta property="article:modified_time" content="2022-09-15T03:01:50+00:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@TribLiveHSSN" />
<meta name="twitter:title" content="Upper St. Clair girls golf coach living American dream after immigrating from Philippines | Trib HSSN" />
<meta name="twitter:description" content="Tuesday’s weather in the Pittsburgh area brought the first nip of fall to the air. But with the temperature still hovering around 70 degrees at mid-afternoon, few folks were ready to consider the prospect of wearing extra layers of clothing." />
<meta name="twitter:creator" content="@TribLiveHSSN" />
<meta name="twitter:image" content="https://assets-tribhssn.triblive.com/2022/09/5429106_web1_ptr-USCGgolf-091422.jpg" />
<meta name="twitter:label1" content="Written by" />
<meta name="twitter:data1" content="Charles Curti" />
<meta name="twitter:label2" content="Est. reading time" />
<meta name="twitter:data2" content="5 minutes" />
<script type="application/ld+json" class="aioseo-schema">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</script>

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Trib HSSN &raquo; Feed" href="https://tribhssn.triblive.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Trib HSSN &raquo; Comments Feed" href="https://tribhssn.triblive.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Trib HSSN &raquo; Upper St. Clair girls golf coach living American dream after immigrating from Philippines Comments Feed" href="https://tribhssn.triblive.com/upper-st-clair-girls-golf-coach-living-american-dream-after-immigrating-from-philippines/feed/" />
<script type="text/javascript">
window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/14.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/tribhssn.triblive.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=6.0.1"}};
/*! This file is auto-generated */
!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode,e=(p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0),i.toDataURL());return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([129777,127995,8205,129778,127999],[129777,127995,8203,129778,127999])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(e=t.source||{}).concatemoji?c(e.concatemoji):e.wpemoji&&e.twemoji&&(c(e.twemoji),c(e.wpemoji)))}(window,document,window._wpemojiSettings);
</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 0.07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<style id='global-styles-inline-css' type='text/css'>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</style>
<link rel='stylesheet' id='heateor_sss_frontend_css-css' href='https://tribhssn.triblive.com/wp-content/plugins/sassy-social-share/public/css/sassy-social-share-public.css?ver=3.3.42' type='text/css' media='all' />
<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/3.2.1/jquery.min.js' id='jquery-js'></script>
<script type='text/javascript' id='seo-automated-link-building-js-extra'>
/* <![CDATA[ */
var seoAutomatedLinkBuilding = {"ajaxUrl":"https:\/\/tribhssn.triblive.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://tribhssn.triblive.com/wp-content/plugins/seo-automated-link-building/js/seo-automated-link-building.js?ver=6.0.1' id='seo-automated-link-building-js'></script>
<link rel="https://api.w.org/" href="https://tribhssn.triblive.com/wp-json/" /><link rel="alternate" type="application/json" href="https://tribhssn.triblive.com/wp-json/wp/v2/posts/252498" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://tribhssn.triblive.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://tribhssn.triblive.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 6.0.1" />
<link rel='shortlink' href='https://tribhssn.triblive.com/?p=252498' />
<link rel="icon" href="https://assets-tribhssn.triblive.com/2017/12/cropped-HSSN_icon_white_150-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://assets-tribhssn.triblive.com/2017/12/cropped-HSSN_icon_white_150-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://assets-tribhssn.triblive.com/2017/12/cropped-HSSN_icon_white_150-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://assets-tribhssn.triblive.com/2017/12/cropped-HSSN_icon_white_150-270x270.jpg" />




</head>
<body class="post-template-default single single-post postid-252498 single-format-standard wp-custom-logo">

<script type="text/javascript">
        ;(function(p,l,o,w,i,n,g){if(!p[i]){p.GlobalAamNamespace=p.GlobalAamNamespace||[];
        p.GlobalAamNamespace.push(i);p[i]=function(){(p[i].q=p[i].q||[]).push(arguments)
        };p[i].q=p[i].q||[];n=l.createElement(o);g=l.getElementsByTagName(o)[0];n.async=1;
        n.src=w;g.parentNode.insertBefore(n,g)}}(window,document,"script","//gadasource.storage.googleapis.com/aam.js","aamsitecertifier"));

 

        window.aamsitecertifier('newTracker', 'cf', 'aamcf.aamsitecertifier.com', {
            idWeb: '483'
        });

 

        window.aamsitecertifier('trackPageView');
    </script>



<script>
			!function(f,b,e,v,n,t,s)
			{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
			n.callMethod.apply(n,arguments):n.queue.push(arguments)};
			if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
			n.queue=[];t=b.createElement(e);t.async=!0;
			t.src=v;s=b.getElementsByTagName(e)[0];
			s.parentNode.insertBefore(t,s)}(window,document,'script',
			'https://connect.facebook.net/en_US/fbevents.js');
			fbq('init', '948412918976583'); 
			fbq('track', 'PageView');
		</script>
<noscript>
			<img height="1" width="1" 
			src="https://www.facebook.com/tr?id=948412918976583&ev=PageView
			&noscript=1"/>
		</noscript>


<div id="fb-root"></div>
<script>
	
		(function(d, s, id) 
		{
			var js, fjs = d.getElementsByTagName(s)[0];
			if (d.getElementById(id)) return;
			js = d.createElement(s); js.id = id;
			js.src = 'https://connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.11';
			fjs.parentNode.insertBefore(js, fjs);
		}(document, 'script', 'facebook-jssdk'));
		
	</script>

<script type='text/javascript'>
        (function() {
            /** CONFIGURATION START **/
            var _sf_async_config = window._sf_async_config = (window._sf_async_config || {});
            _sf_async_config.uid = 66938; 
            _sf_async_config.domain = 'tribhssn.triblive.com'; // DON'T INCLUDE HTTP(S) OR WWW
            _sf_async_config.useCanonical = true;
                _sf_async_config.useCanonicalDomain = true;            _sf_async_config.sections = 'Single'; //SET PAGE SECTION(S)
            _sf_async_config.authors = 'Charles Curti'; //SET PAGE AUTHOR(S)
            /** CONFIGURATION END **/
            function loadChartbeat() {
                var e = document.createElement('script');
                var n = document.getElementsByTagName('script')[0];
                e.type = 'text/javascript';
                e.async = true;
                e.src = '//static.chartbeat.com/js/chartbeat.js';
                n.parentNode.insertBefore(e, n);
            }
            loadChartbeat();
         })();
    </script>
<script async src="//static.chartbeat.com/js/chartbeat_mab.js"></script>


<header data-sj-ignore>
<div class="utility-bar d-none d-md-block">
<div class="container">
<div class="row" style="min-height: 20px;">
<div class="col-md-1" style="min-height: 20px;">
<a href="https://triblive.com" target="_blank" style="padding-left:0;">
<img src="https://tribhssn.triblive.com/wp-content/themes/hssn/images/TribLIVElogo.png" alt="TribLIVE Logo">
</a>
</div>
<div class="col-flex col-md-9" style="min-height: 20px;display:flex;">
<div class="trib-menu-wrapper">
<div class="menu-hssn-trib-menu-container"><ul id="menu-hssn-trib-menu" class="list-unstyled d-flex flex-wrap flex-row sub-nav"><li id="menu-item-62073" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62073"><a href="https://triblive.com/sports/">Sports</a></li>
<li id="menu-item-62074" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62074"><a href="https://triblive.com/news/">News</a></li>
<li id="menu-item-62075" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62075"><a href="https://triblive.com/local/">Local</a></li>
<li id="menu-item-62076" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62076"><a href="https://triblive.com/opinion/">Opinion</a></li>
<li id="menu-item-62077" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62077"><a href="https://triblive.com/aande/">A&amp;E</a></li>
<li id="menu-item-62078" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62078"><a href="https://triblive.com/lifestyles/">Lifestyles</a></li>
<li id="menu-item-62079" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62079"><a href="https://triblive.com/home/video/">Video</a></li>
<li id="menu-item-62080" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62080"><a href="https://triblive.com/obituaries/">Obituaries</a></li>
</ul></div> </div>
<form method="get" action="/search/" class="search-area" style="z-index: 999;">
<input class="form-control border-end-0 border rounded-pill" type="text" placeholder="Search" name="search">
<button class="btn btn-outline-secondary bg-white border-start-0 border rounded-pill ms-n3" type="submit">
Search
</button>
</form>
</div>
<div class="col-md-2" style="min-height: 20px;">
<a href="http://wpial.org" target="_blank" style="float: right;">
<img src="https://tribhssn.triblive.com/wp-content/themes/hssn/images/wpial_whitesolid.png" alt="WPIAL Logo White" class="img-fluid">
</a>
</div>
</div>
</div>
</div>
<div class="container-fluid d-none d-md-block">
<div class="row text-center logo">
<div class="col">
</div>
</div>
</div>
<nav class="main-nav navbar navbar-expand-md bg-dark navbar-dark">
<div class="container-fluid">
<button class="navbar-toggler" type="button" data-toggle="collapse" aria-expanded="false" aria-label="Toggle navigation" data-target="#navbar-main-nav">
<i class="fa fa-bars" aria-hidden="true"></i>
<a href="https://tribhssn.triblive.com/">
<img src="https://tribhssn.triblive.com/wp-content/themes/hssn/images/hssn-nav-logo.png" alt="HSSN Logo" class="img-fluid brand-mobile">
</a>
</button>
<div id="navbar-main-nav" class="collapse navbar-collapse"><ul id="menu-hssn-main-menu" class="navbar-nav"><li id="menu-item-62018" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-62018 nav-item"><a href="https://tribhssn.triblive.com/schools/" class="nav-link">Schools</a><li id="menu-item-136552" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-136552 nav-item dropdown"><a href="https://tribhssn.triblive.com/sports/" class="nav-link dropdown-toggle" data-toggle="dropdown">Sports</a>
<div class="dropdown-menu">
<a href="https://tribhssn.triblive.com/category/baseball/" class="dropdown-item">Baseball</a><a href="https://tribhssn.triblive.com/category/basketball/" class="dropdown-item">Basketball</a><a href="https://tribhssn.triblive.com/category/cross-country/" class="dropdown-item">Cross Country</a><a href="https://tribhssn.triblive.com/category/field-hockey/" class="dropdown-item">Field Hockey</a><a href="https://tribhssn.triblive.com/category/football/" class="dropdown-item">Football</a><a href="https://tribhssn.triblive.com/category/golf/" class="dropdown-item">Golf</a><a href="https://tribhssn.triblive.com/category/gymnastics/" class="dropdown-item">Gymnastics</a><a href="https://tribhssn.triblive.com/category/hockey/" class="dropdown-item">Hockey</a><a href="https://tribhssn.triblive.com/category/lacrosse/" class="dropdown-item">Lacrosse</a><a href="https://tribhssn.triblive.com/category/rifle/" class="dropdown-item">Rifle</a><a href="https://tribhssn.triblive.com/category/soccer/" class="dropdown-item">Soccer</a><a href="https://tribhssn.triblive.com/category/softball/" class="dropdown-item">Softball</a><a href="https://tribhssn.triblive.com/category/swimming/" class="dropdown-item">Swimming</a><a href="https://tribhssn.triblive.com/category/tennis/" class="dropdown-item">Tennis</a><a href="https://tribhssn.triblive.com/category/track-and-field/" class="dropdown-item">Track and Field</a><a href="https://tribhssn.triblive.com/category/volleyball/" class="dropdown-item">Volleyball</a><a href="https://tribhssn.triblive.com/category/wrestling/" class="dropdown-item">Wrestling</a><a href="https://tribhssn.triblive.com/category/other/" class="dropdown-item">Other Sports</a><a href="https://tribhssn.triblive.com/sports/" class="dropdown-item">All Sports</a></div>
<li id="menu-item-62045" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-62045 nav-item"><a href="https://tribhssn.triblive.com/scores/" class="nav-link">Scores</a><li id="menu-item-133836" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-133836 nav-item"><a href="https://tribhssn.triblive.com/stats/" class="nav-link">Stats</a><li id="menu-item-133837" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-133837 nav-item"><a href="https://tribhssn.triblive.com/standings/" class="nav-link">Standings</a><li id="menu-item-240493" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-240493 nav-item dropdown"><a href="#" class="nav-link dropdown-toggle" data-toggle="dropdown">Broadcasts</a>
<div class="dropdown-menu">
<a href="https://tribhssn.triblive.com/broadcast-calendar/" class="dropdown-item">Broadcast Calendar</a><a href="https://tribhssn.triblive.com/todays-broadcast/" class="dropdown-item">Today’s Broadcasts</a><a href="https://tribhssn.triblive.com/podcasts/" class="dropdown-item">Podcasts</a><a href="https://tribhssn.triblive.com/faq/" class="dropdown-item">Frequently Asked Questions</a></div>
<li id="menu-item-95914" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-95914 nav-item dropdown"><a href="https://tribhssn.triblive.com/high-school-brackets/" class="nav-link dropdown-toggle" data-toggle="dropdown">Brackets</a>
<div class="dropdown-menu">
<a href="https://tribhssn.triblive.com/high-school-brackets/wpial/" class="dropdown-item">WPIAL</a><a href="https://tribhssn.triblive.com/high-school-brackets/piaa/" class="dropdown-item">PIAA</a></div>
<li id="menu-item-246876" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-246876 nav-item"><a href="https://mediakit.triblive.com/triblive-high-school-sports-network/" class="nav-link">Advertise With Us</a><li class="d-none d-md-block order-1 nav-item nav-logo"><a href="/" class="nav-link"><img src="https://tribhssn.triblive.com/wp-content/themes/hssn/images/hssn-nav-logo.png" alt="HSSN nav Logo" class="img-fluid brand"></a></li></ul></div> </div>
</nav>

<div class="fixed-bottom">

<div id='div-gpt-ad-1380843670843-0' class="ad">
<script type="text/javascript">
		
           	if (SponsorBar_ATFactive > 0){
			
           		googletag.cmd.push(function() { 
				
				googletag.display('div-gpt-ad-1380843670843-0'); });
           	}
     	</script>
</div>
</div>

<div class="container">
<div class="row no-gutters space">
<div class="col">
<ul id="menu-hssn-stat-menu" class="navbar-nav d-flex flex-wrap flex-row hssn-gray sub-nav justify-content-center"><li id="menu-item-133834" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-133834 nav-item"><a href="https://tribhssn.triblive.com/rankings/" class="nav-link">Rankings</a><li id="menu-item-133835" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-133835 nav-item"><a href="https://tribhssn.triblive.com/recruiting/" class="nav-link">Recruiting</a></ul> </div>
</div>
<div class="row no-gutters text-center space">
<div class="col">

<div id='div-gpt-ad-1380843670843-35' class="ad">
<script type="text/javascript">
		
           	if (Leaderboard_ATF_1active > 0){
			
           		googletag.cmd.push(function() { 
				
				googletag.display('div-gpt-ad-1380843670843-35'); });
           	}
     	</script>
</div>
</div>
</div> 
</div>
</header>
<script src="https://tribhssn.triblive.com/wp-content/themes/hssn/assets/functions/scripts/fp.js"></script>


<div class="container space page-content">
<div class="row no-gutters">
<div class="col-md-7 content-container">
<h1>Upper St. Clair girls golf coach living American dream after immigrating from Philippines</h1>
<p><strong>By: <span class="author-byline"><a href="https://tribhssn.triblive.com/author/charles-curti/" title="Posts by Charles Curti" rel="author">Charles Curti</a></span>

</strong><br />
Wednesday, September 14, 2022 | 7:01 PM</p>
<hr>
<div id="postCarousel" class="carousel slide" data-interval="false" data-ride="carousel">
<div class="carousel-inner">
<div class="carousel-item active">
<figure class="figure">
<img id="photo-id_252499" class="img-fluid figure-img nofotomoto" src="https://assets-tribhssn.triblive.com/2022/09/5429106_web1_ptr-USCGgolf-091422.jpg" alt="5429106_web1_ptr-USCGgolf-091422" title="5429106_web1_ptr-USCGgolf-091422" />
<figcaption class="figure-caption">
<div class="row">
<div class="col">
<div class="credit float-right">
Submitted by Mercedes Epondulan </div>
</div>
</div>
<div class="row">
<div class="col">
<div class="caption clearfix">
<p>Mercedes Epondulan (kneeling) is in her first season as the Upper St. Clair girls golf coach. Epondulan came to the United States from the Philippines when she was 12.</p> </div>
</div> 
</div> 
</figcaption>
</figure>
</div>
<div class="carousel-item">
<figure class="figure">
<img id="photo-id_252500" class="img-fluid figure-img nofotomoto" src="https://assets-tribhssn.triblive.com/2022/09/5429106_web1_ptr-epondulan-091422.jpg" alt="5429106_web1_ptr-epondulan-091422" title="5429106_web1_ptr-epondulan-091422" />
<figcaption class="figure-caption">
<div class="row">
<div class="col">
<div class="credit float-right">
Cal (Pa.) Athletics </div>
</div>
</div>
<div class="row">
<div class="col">
<div class="caption clearfix">
<p>Allderdice grad Mercedes Epondulan played golf at Cal (Pa.) from 2013-17.</p> </div>
</div> 
</div> 
</figcaption>
</figure>
</div>
<a class="carousel-control-prev" href="#postCarousel" role="button" data-slide="prev">
<span class="carousel-control-prev-icon" aria-hidden="true"></span>
<span class="sr-only">Previous</span>
</a>
<a class="carousel-control-next" href="#postCarousel" role="button" data-slide="next">
<span class="carousel-control-next-icon" aria-hidden="true"></span>
<span class="sr-only">Next</span>
</a>
</div>
</div>
<div class='heateorSssClear'></div><div style="float:right" class='heateor_sss_sharing_container heateor_sss_horizontal_sharing' data-heateor-sss-href='https://tribhssn.triblive.com/upper-st-clair-girls-golf-coach-living-american-dream-after-immigrating-from-philippines/'><div class='heateor_sss_sharing_title' style="font-weight:bold"></div><div class="heateor_sss_sharing_ul"><a class="heateor_sss_facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Ftribhssn.triblive.com%2Fupper-st-clair-girls-golf-coach-living-american-dream-after-immigrating-from-philippines%2F" title="Facebook" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#3c589a;width:30px;height:30px;border-radius:5px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-5 -5 42 42"><path d="M17.78 27.5V17.008h3.522l.527-4.09h-4.05v-2.61c0-1.182.33-1.99 2.023-1.99h2.166V4.66c-.375-.05-1.66-.16-3.155-.16-3.123 0-5.26 1.905-5.26 5.405v3.016h-3.53v4.09h3.53V27.5h4.223z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_twitter" href="https://twitter.com/intent/tweet?text=Upper%20St.%20Clair%20girls%20golf%20coach%20living%20American%20dream%20after%20immigrating%20from%20Philippines&url=https%3A%2F%2Ftribhssn.triblive.com%2Fupper-st-clair-girls-golf-coach-living-american-dream-after-immigrating-from-philippines%2F" title="Twitter" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_twitter" style="background-color:#55acee;width:30px;height:30px;border-radius:5px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-4 -4 39 39"><path d="M28 8.557a9.913 9.913 0 0 1-2.828.775 4.93 4.93 0 0 0 2.166-2.725 9.738 9.738 0 0 1-3.13 1.194 4.92 4.92 0 0 0-3.593-1.55 4.924 4.924 0 0 0-4.794 6.049c-4.09-.21-7.72-2.17-10.15-5.15a4.942 4.942 0 0 0-.665 2.477c0 1.71.87 3.214 2.19 4.1a4.968 4.968 0 0 1-2.23-.616v.06c0 2.39 1.7 4.38 3.952 4.83-.414.115-.85.174-1.297.174-.318 0-.626-.03-.928-.086a4.935 4.935 0 0 0 4.6 3.42 9.893 9.893 0 0 1-6.114 2.107c-.398 0-.79-.023-1.175-.068a13.953 13.953 0 0 0 7.55 2.213c9.056 0 14.01-7.507 14.01-14.013 0-.213-.005-.426-.015-.637.96-.695 1.795-1.56 2.455-2.55z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_instagram" href="https://www.instagram.com/" title="Instagram" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#53beee;width:30px;height:30px;border-radius:5px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" version="1.1" viewBox="-10 -10 148 148" width="100%" height="100%" xml:space="preserve" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><g><g><path d="M86,112H42c-14.336,0-26-11.663-26-26V42c0-14.337,11.664-26,26-26h44c14.337,0,26,11.663,26,26v44 C112,100.337,100.337,112,86,112z M42,24c-9.925,0-18,8.074-18,18v44c0,9.925,8.075,18,18,18h44c9.926,0,18-8.075,18-18V42 c0-9.926-8.074-18-18-18H42z" fill="#fff"></path></g><g><path d="M64,88c-13.234,0-24-10.767-24-24c0-13.234,10.766-24,24-24s24,10.766,24,24C88,77.233,77.234,88,64,88z M64,48c-8.822,0-16,7.178-16,16s7.178,16,16,16c8.822,0,16-7.178,16-16S72.822,48,64,48z" fill="#fff"></path></g><g><circle cx="89.5" cy="38.5" fill="#fff" r="5.5"></circle></g></g></svg></span></a><a class="heateor_sss_email" onclick="window.open('mailto:?subject=' + decodeURIComponent('Upper%20St.%20Clair%20girls%20golf%20coach%20living%20American%20dream%20after%20immigrating%20from%20Philippines' ).replace('&', '%26') + '&body=' + decodeURIComponent('https%3A%2F%2Ftribhssn.triblive.com%2Fupper-st-clair-girls-golf-coach-living-american-dream-after-immigrating-from-philippines%2F' ), '_blank')" title="Email" rel="nofollow noopener" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#649a3f;width:30px;height:30px;border-radius:5px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-4 -4 43 43"><path d="M 5.5 11 h 23 v 1 l -11 6 l -11 -6 v -1 m 0 2 l 11 6 l 11 -6 v 11 h -22 v -11" stroke-width="1" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_pinterest" onclick="javascript:void( (function() {var e=document.createElement('script' );e.setAttribute('type','text/javascript' );e.setAttribute('charset','UTF-8' );e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e)})());" title="Pinterest" rel="nofollow noopener" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_pinterest" style="background-color:#cc2329;width:30px;height:30px;border-radius:5px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-2 -2 35 35"><path fill="#fff" d="M16.539 4.5c-6.277 0-9.442 4.5-9.442 8.253 0 2.272.86 4.293 2.705 5.046.303.125.574.005.662-.33.061-.231.205-.816.27-1.06.088-.331.053-.447-.191-.736-.532-.627-.873-1.439-.873-2.591 0-3.338 2.498-6.327 6.505-6.327 3.548 0 5.497 2.168 5.497 5.062 0 3.81-1.686 7.025-4.188 7.025-1.382 0-2.416-1.142-2.085-2.545.397-1.674 1.166-3.48 1.166-4.689 0-1.081-.581-1.983-1.782-1.983-1.413 0-2.548 1.462-2.548 3.419 0 1.247.421 2.091.421 2.091l-1.699 7.199c-.505 2.137-.076 4.755-.039 5.019.021.158.223.196.314.077.13-.17 1.813-2.247 2.384-4.324.162-.587.929-3.631.929-3.631.46.876 1.801 1.646 3.227 1.646 4.247 0 7.128-3.871 7.128-9.053.003-3.918-3.317-7.568-8.361-7.568z" /></svg></span></a><a class="heateor_sss_button_linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Ftribhssn.triblive.com%2Fupper-st-clair-girls-golf-coach-living-american-dream-after-immigrating-from-philippines%2F&title=Upper%20St.%20Clair%20girls%20golf%20coach%20living%20American%20dream%20after%20immigrating%20from%20Philippines" title="Linkedin" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_linkedin" style="background-color:#0077b5;width:30px;height:30px;border-radius:5px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><path d="M6.227 12.61h4.19v13.48h-4.19V12.61zm2.095-6.7a2.43 2.43 0 0 1 0 4.86c-1.344 0-2.428-1.09-2.428-2.43s1.084-2.43 2.428-2.43m4.72 6.7h4.02v1.84h.058c.56-1.058 1.927-2.176 3.965-2.176 4.238 0 5.02 2.792 5.02 6.42v7.395h-4.183v-6.56c0-1.564-.03-3.574-2.178-3.574-2.18 0-2.514 1.7-2.514 3.46v6.668h-4.187V12.61z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_reddit" href="https://reddit.com/submit?url=https%3A%2F%2Ftribhssn.triblive.com%2Fupper-st-clair-girls-golf-coach-living-american-dream-after-immigrating-from-philippines%2F&title=Upper%20St.%20Clair%20girls%20golf%20coach%20living%20American%20dream%20after%20immigrating%20from%20Philippines" title="Reddit" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_reddit" style="background-color:#ff5700;width:30px;height:30px;border-radius:5px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-3.5 -3.5 39 39"><path d="M28.543 15.774a2.953 2.953 0 0 0-2.951-2.949 2.882 2.882 0 0 0-1.9.713 14.075 14.075 0 0 0-6.85-2.044l1.38-4.349 3.768.884a2.452 2.452 0 1 0 .24-1.176l-4.274-1a.6.6 0 0 0-.709.4l-1.659 5.224a14.314 14.314 0 0 0-7.316 2.029 2.908 2.908 0 0 0-1.872-.681 2.942 2.942 0 0 0-1.618 5.4 5.109 5.109 0 0 0-.062.765c0 4.158 5.037 7.541 11.229 7.541s11.22-3.383 11.22-7.541a5.2 5.2 0 0 0-.053-.706 2.963 2.963 0 0 0 1.427-2.51zm-18.008 1.88a1.753 1.753 0 0 1 1.73-1.74 1.73 1.73 0 0 1 1.709 1.74 1.709 1.709 0 0 1-1.709 1.711 1.733 1.733 0 0 1-1.73-1.711zm9.565 4.968a5.573 5.573 0 0 1-4.081 1.272h-.032a5.576 5.576 0 0 1-4.087-1.272.6.6 0 0 1 .844-.854 4.5 4.5 0 0 0 3.238.927h.032a4.5 4.5 0 0 0 3.237-.927.6.6 0 1 1 .844.854zm-.331-3.256a1.726 1.726 0 1 1 1.709-1.712 1.717 1.717 0 0 1-1.712 1.712z" fill="#fff" /></svg></span></a><a class="heateor_sss_button_print" onclick="window.print()" title="Print" rel="nofollow noopener" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_print" style="background-color:#fd6500;width:30px;height:30px;border-radius:5px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><path fill="#fff" stroke="#fff" stroke-width=".1" d="M4.467 14.305h23.065v6.498H4.467v-6.498z" /><path fill="#DCDCDC" stroke="#fff" stroke-width=".1" d="M5.228 12.83H26.77l.745 1.39H4.485l.743-1.39z" /><path d="M9.19 8.118h13.467v6.106H9.19z" /><path fill="#fff" stroke="#fff" stroke-width=".1" d="M9.844 6.516h12.312v7.31H9.844z" /><path stroke="#fff" stroke-width=".1" d="M8.602 17.37h14.574v3.396H8.602z" /><path fill="#fff" stroke="#fff" stroke-width=".1" d="M10.152 17.97h11.27l2.233 7.515H7.92l2.232-7.514z" /></svg></span></a><a class="heateor_sss_more" title="More" rel="nofollow noopener" style="font-size: 32px!important;border:0;box-shadow:none;display:inline-block!important;font-size:16px;padding:0 4px;vertical-align: middle;display:inline;" href="https://tribhssn.triblive.com/upper-st-clair-girls-golf-coach-living-american-dream-after-immigrating-from-philippines/" onclick="event.preventDefault()"><span class="heateor_sss_svg" style="background-color:#ee8e2d;width:30px;height:30px;border-radius:5px;display:inline-block!important;opacity:1;float:left;font-size:32px!important;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;display:inline;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box;" onclick="heateorSssMoreSharingPopup(this, 'https://tribhssn.triblive.com/upper-st-clair-girls-golf-coach-living-american-dream-after-immigrating-from-philippines/', 'Upper%20St.%20Clair%20girls%20golf%20coach%20living%20American%20dream%20after%20immigrating%20from%20Philippines', '' )"><svg xmlns="http://www.w3.org/2000/svg" style="display:block;" width="100%" height="100%" viewBox="-4 -4 38 38"><circle cx="10" cy="15" r="3" fill="#fff"></circle><circle cx="20" cy="10" r="3" fill="#fff"></circle><circle cx="20" cy="20" r="3" fill="#fff"></circle><path d="M 10 15 L 20 10 m 0 10 L 10 15" class="heateor_sss_svg_stroke heateor_sss_no_fill" stroke-width="2" stroke="#fff"></path></svg></span></a></div><div class="heateorSssClear"></div></div><div class='heateorSssClear'></div><p>Tuesday&rsquo;s weather in the Pittsburgh area brought the first nip of fall to the air. But with the temperature still hovering around 70 degrees at mid-afternoon, few folks were ready to consider the prospect of wearing extra layers of clothing.</p>
<p><a href="https://tribhssn.triblive.com/schools/upper-st-clair/" data-internallinksmanager029f6b8e52c="153" title="Upper St. Clair" target="_blank" rel="noopener">Upper St. Clair</a> girls golf coach Mercedes Epondulan was one of the few. Even after nearly two decades in Western Pennsylvania, she still isn&rsquo;t used to the chill.</p>
<p>&ldquo;This is cold for me,&rdquo; she said with a laugh.</p>
<p>For someone who spent the first 12 years of her life living in the sultry climate of the Philippines, it is easy to see how mid-September in Pittsburgh could seem brisk.</p>
<p>Epondulan, 29 and in her first season with the Panthers, is living the quintessential American dream: Part of a large Filipino family who came to the United States in search of opportunity, she has found her niche in golf. She played at <a href="https://tribhssn.triblive.com/schools/allderdice/" data-internallinksmanager029f6b8e52c="3" title="Allderdice" target="_blank" rel="noopener">Allderdice</a> then at Cal (Pa.), and now, in addition to coaching at <a href="https://tribhssn.triblive.com/schools/upper-st-clair/" data-internallinksmanager029f6b8e52c="153" title="Upper St. Clair" target="_blank" rel="noopener">Upper St. Clair</a>, she is working as a PGA apprentice at <a href="https://tribhssn.triblive.com/schools/valley/" data-internallinksmanager029f6b8e52c="154" title="Valley" target="_blank" rel="noopener">Valley</a> Brook Country Club with an eye toward being a teaching professional.</p>
<p>&ldquo;Just being here, being a coach, who would have thought that I would be a coach?&rdquo; Epondulan said. &ldquo;It&rsquo;s just surreal to be coaching a sport that I hated.&rdquo;</p>
<p>The journey began with her sister, Elpidia, the eldest of Epondulan&rsquo;s eight older siblings. The family long had talked about coming to the United States, and Elpidia was the first to take the plunge.</p>
<p>She had met a pen pal &mdash; that&rsquo;s the old-school pen-and-paper equivalent of meeting someone online &mdash; from the Pittsburgh area, so she put down roots here. Elpidia worked multiple jobs until she had enough money to bring her mother over.</p>
<p>The rest of the family followed &mdash; their father and a brother remained in the Philippines &mdash; including the &ldquo;baby,&rdquo; 12-year-old Mercedes.</p>
<p>As might be expected, the transition was difficult initially. Epondulan had grown up on one of the Philippines&rsquo; small islands where it was mostly mountains and ocean, and everyone knew almost everyone else.</p>
<p>Then there was the language barrier. Epondulan, though she knew some English, spoke primarily Bisaya, a dialect of the Philippines&rsquo; main language, Tagalog.</p>
<p>&ldquo;Anytime somebody would talk to me or ask me a question,&rdquo; she said, &ldquo;I would have to pause to translate it into at least two different languages and then understand it and then translate it back.&rdquo;</p>
<p>As the family began to assimilate into their American surroundings, the children were encouraged to get involved in an activity. Epondulan&rsquo;s brother-in-law, David, introduced her and her sister, Mary, to golf through the First Tee of Pittsburgh and Pittsburgh Youth Golf Foundation. (Mary Epondulan also played a year of golf at Cal.)</p>
<p>At first, Epondulan was unimpressed. She found it boring standing over a little, white ball for hours. On top of it, everyone spoke too quickly for her to understand most of the conversations. Her family, however, insisted she stick with it, and she wound up falling in love with the game. Perhaps just as importantly, Epondulan fell in love with the atmosphere around the First Tee.</p>
<p>&ldquo;The First Tee was diverse. It still is,&rdquo; she said. &ldquo;The people and coaches were helpful, and they knew English wasn&rsquo;t my first language. &#8230; They were very kind to my sister and me. I was making friends, and now it felt like I belonged somewhere.&rdquo;</p>
<p>She began pursuing the game in earnest, playing well enough at Allderdice to get a shot at Cal (Pa.). She played for the Vulcans from 2013-17, posting a scoring average of 85.5 in 11 matches during her senior season.</p>
<p>The job at Upper St. Clair fell into her lap. Mike Papson, head professional at <a href="https://tribhssn.triblive.com/schools/valley/" data-internallinksmanager029f6b8e52c="154" title="Valley" target="_blank" rel="noopener">Valley</a> Brook, told Epondulan that USC was looking for a girls golf coach, and the prospect intrigued her.</p>
<p>&ldquo;I said, &lsquo;How long do I have? How long before I need to tell you?&rsquo; &rdquo; she said. &ldquo;He said, &lsquo;Tomorrow.&rsquo; I had less than 24 hours to let him know.&rdquo;</p>
<p>The Panthers have been competitive in Epondulan&rsquo;s first season. After Tuesday&rsquo;s tri-match win over <a href="https://tribhssn.triblive.com/schools/bethel-park/" data-internallinksmanager029f6b8e52c="18" title="Bethel Park" target="_blank" rel="noopener">Bethel Park</a> and <a href="https://tribhssn.triblive.com/schools/elizabeth-forward/" data-internallinksmanager029f6b8e52c="48" title="Elizabeth Forward" target="_blank" rel="noopener">Elizabeth Forward</a>, the Panthers stood at 5-7-1 overall.</p>
<p>Despite Epondulan&rsquo;s hasty introduction to the team, the players believe the move has worked.</p>
<p>&ldquo;She&rsquo;s such a nice coach, and we&rsquo;ve all been able to adapt really nicely to her,&rdquo; said senior captain Anna McElligott.</p>
<p>Added fellow senior captain Natalie Zunic: &ldquo;She has taught me a lot of new things with my golf game. She&rsquo;s a really good teacher, and, personally, I think she&rsquo;s a really good coach.&rdquo;</p>
<p>Once the high school season ends, Epondulan, now an American citizen, will return her focus to her apprenticeship. There are three levels aspiring pros must pass &mdash; the third level has two tiers &mdash; and Epondulan is working on Level 2. Her primary duties at Valley Brook are giving lessons to juniors and beginners, but, eventually, she wants to be able to teach players of all levels.</p>
<p>She also has a special desire to help the First Tee.</p>
<p>&ldquo;I am very glad and fortunate to get this opportunity, and, hopefully, down the road, I want to give back,&rdquo; she said. &ldquo;And not just to Valley Brook but to the First Tee. Golf is a very expensive sport, and there&rsquo;s not a lot of young girls, so I just want to teach and give back.&rdquo;</p>
<p>Perhaps one day, golf will enable her to make an impact on someone just like her, a young person who is seeking their own version of the American dream. But it&rsquo;s clear she already has inspired her players at Upper St. Clair.</p>
<p>&ldquo;She has a lot of courage to do that, leave her country and all of that,&rdquo; Zunic said. &ldquo;I thought it was pretty cool of her and took a lot of bravery.&rdquo;</p>
<p>Added McElligott: &ldquo;It&rsquo;s an amazing story, and I think it shows all of us that anything is possible if you have enough courage to dream about it.&rdquo;</p>
<div class='heateor_sss_sharing_container heateor_sss_vertical_sharing heateor_sss_bottom_sharing' style='width:39px;left: -10px;top: 100px;-webkit-box-shadow:none;box-shadow:none;' data-heateor-sss-href='https://tribhssn.triblive.com/upper-st-clair-girls-golf-coach-living-american-dream-after-immigrating-from-philippines/'><div class="heateor_sss_sharing_ul"><a class="heateor_sss_facebook" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Ftribhssn.triblive.com%2Fupper-st-clair-girls-golf-coach-living-american-dream-after-immigrating-from-philippines%2F" title="Facebook" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#3c589a;width:35px;height:35px;border-radius:5px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-5 -5 42 42"><path d="M17.78 27.5V17.008h3.522l.527-4.09h-4.05v-2.61c0-1.182.33-1.99 2.023-1.99h2.166V4.66c-.375-.05-1.66-.16-3.155-.16-3.123 0-5.26 1.905-5.26 5.405v3.016h-3.53v4.09h3.53V27.5h4.223z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_twitter" href="https://twitter.com/intent/tweet?text=Upper%20St.%20Clair%20girls%20golf%20coach%20living%20American%20dream%20after%20immigrating%20from%20Philippines&url=https%3A%2F%2Ftribhssn.triblive.com%2Fupper-st-clair-girls-golf-coach-living-american-dream-after-immigrating-from-philippines%2F" title="Twitter" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_twitter" style="background-color:#55acee;width:35px;height:35px;border-radius:5px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-4 -4 39 39"><path d="M28 8.557a9.913 9.913 0 0 1-2.828.775 4.93 4.93 0 0 0 2.166-2.725 9.738 9.738 0 0 1-3.13 1.194 4.92 4.92 0 0 0-3.593-1.55 4.924 4.924 0 0 0-4.794 6.049c-4.09-.21-7.72-2.17-10.15-5.15a4.942 4.942 0 0 0-.665 2.477c0 1.71.87 3.214 2.19 4.1a4.968 4.968 0 0 1-2.23-.616v.06c0 2.39 1.7 4.38 3.952 4.83-.414.115-.85.174-1.297.174-.318 0-.626-.03-.928-.086a4.935 4.935 0 0 0 4.6 3.42 9.893 9.893 0 0 1-6.114 2.107c-.398 0-.79-.023-1.175-.068a13.953 13.953 0 0 0 7.55 2.213c9.056 0 14.01-7.507 14.01-14.013 0-.213-.005-.426-.015-.637.96-.695 1.795-1.56 2.455-2.55z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_instagram" href="https://www.instagram.com/" title="Instagram" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#53beee;width:35px;height:35px;border-radius:5px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" version="1.1" viewBox="-10 -10 148 148" width="100%" height="100%" xml:space="preserve" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink"><g><g><path d="M86,112H42c-14.336,0-26-11.663-26-26V42c0-14.337,11.664-26,26-26h44c14.337,0,26,11.663,26,26v44 C112,100.337,100.337,112,86,112z M42,24c-9.925,0-18,8.074-18,18v44c0,9.925,8.075,18,18,18h44c9.926,0,18-8.075,18-18V42 c0-9.926-8.074-18-18-18H42z" fill="#fff"></path></g><g><path d="M64,88c-13.234,0-24-10.767-24-24c0-13.234,10.766-24,24-24s24,10.766,24,24C88,77.233,77.234,88,64,88z M64,48c-8.822,0-16,7.178-16,16s7.178,16,16,16c8.822,0,16-7.178,16-16S72.822,48,64,48z" fill="#fff"></path></g><g><circle cx="89.5" cy="38.5" fill="#fff" r="5.5"></circle></g></g></svg></span></a><a class="heateor_sss_email" onclick="window.open('mailto:?subject=' + decodeURIComponent('Upper%20St.%20Clair%20girls%20golf%20coach%20living%20American%20dream%20after%20immigrating%20from%20Philippines' ).replace('&', '%26') + '&body=' + decodeURIComponent('https%3A%2F%2Ftribhssn.triblive.com%2Fupper-st-clair-girls-golf-coach-living-american-dream-after-immigrating-from-philippines%2F' ), '_blank')" title="Email" rel="nofollow noopener" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg" style="background-color:#649a3f;width:35px;height:35px;border-radius:5px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-4 -4 43 43"><path d="M 5.5 11 h 23 v 1 l -11 6 l -11 -6 v -1 m 0 2 l 11 6 l 11 -6 v 11 h -22 v -11" stroke-width="1" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_pinterest" onclick="javascript:void( (function() {var e=document.createElement('script' );e.setAttribute('type','text/javascript' );e.setAttribute('charset','UTF-8' );e.setAttribute('src','//assets.pinterest.com/js/pinmarklet.js?r='+Math.random()*99999999);document.body.appendChild(e)})());" title="Pinterest" rel="nofollow noopener" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_pinterest" style="background-color:#cc2329;width:35px;height:35px;border-radius:5px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-2 -2 35 35"><path fill="#fff" d="M16.539 4.5c-6.277 0-9.442 4.5-9.442 8.253 0 2.272.86 4.293 2.705 5.046.303.125.574.005.662-.33.061-.231.205-.816.27-1.06.088-.331.053-.447-.191-.736-.532-.627-.873-1.439-.873-2.591 0-3.338 2.498-6.327 6.505-6.327 3.548 0 5.497 2.168 5.497 5.062 0 3.81-1.686 7.025-4.188 7.025-1.382 0-2.416-1.142-2.085-2.545.397-1.674 1.166-3.48 1.166-4.689 0-1.081-.581-1.983-1.782-1.983-1.413 0-2.548 1.462-2.548 3.419 0 1.247.421 2.091.421 2.091l-1.699 7.199c-.505 2.137-.076 4.755-.039 5.019.021.158.223.196.314.077.13-.17 1.813-2.247 2.384-4.324.162-.587.929-3.631.929-3.631.46.876 1.801 1.646 3.227 1.646 4.247 0 7.128-3.871 7.128-9.053.003-3.918-3.317-7.568-8.361-7.568z" /></svg></span></a><a class="heateor_sss_button_linkedin" href="https://www.linkedin.com/shareArticle?mini=true&url=https%3A%2F%2Ftribhssn.triblive.com%2Fupper-st-clair-girls-golf-coach-living-american-dream-after-immigrating-from-philippines%2F&title=Upper%20St.%20Clair%20girls%20golf%20coach%20living%20American%20dream%20after%20immigrating%20from%20Philippines" title="Linkedin" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_linkedin" style="background-color:#0077b5;width:35px;height:35px;border-radius:5px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><path d="M6.227 12.61h4.19v13.48h-4.19V12.61zm2.095-6.7a2.43 2.43 0 0 1 0 4.86c-1.344 0-2.428-1.09-2.428-2.43s1.084-2.43 2.428-2.43m4.72 6.7h4.02v1.84h.058c.56-1.058 1.927-2.176 3.965-2.176 4.238 0 5.02 2.792 5.02 6.42v7.395h-4.183v-6.56c0-1.564-.03-3.574-2.178-3.574-2.18 0-2.514 1.7-2.514 3.46v6.668h-4.187V12.61z" fill="#fff"></path></svg></span></a><a class="heateor_sss_button_reddit" href="https://reddit.com/submit?url=https%3A%2F%2Ftribhssn.triblive.com%2Fupper-st-clair-girls-golf-coach-living-american-dream-after-immigrating-from-philippines%2F&title=Upper%20St.%20Clair%20girls%20golf%20coach%20living%20American%20dream%20after%20immigrating%20from%20Philippines" title="Reddit" rel="nofollow noopener" target="_blank" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_reddit" style="background-color:#ff5700;width:35px;height:35px;border-radius:5px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="-3.5 -3.5 39 39"><path d="M28.543 15.774a2.953 2.953 0 0 0-2.951-2.949 2.882 2.882 0 0 0-1.9.713 14.075 14.075 0 0 0-6.85-2.044l1.38-4.349 3.768.884a2.452 2.452 0 1 0 .24-1.176l-4.274-1a.6.6 0 0 0-.709.4l-1.659 5.224a14.314 14.314 0 0 0-7.316 2.029 2.908 2.908 0 0 0-1.872-.681 2.942 2.942 0 0 0-1.618 5.4 5.109 5.109 0 0 0-.062.765c0 4.158 5.037 7.541 11.229 7.541s11.22-3.383 11.22-7.541a5.2 5.2 0 0 0-.053-.706 2.963 2.963 0 0 0 1.427-2.51zm-18.008 1.88a1.753 1.753 0 0 1 1.73-1.74 1.73 1.73 0 0 1 1.709 1.74 1.709 1.709 0 0 1-1.709 1.711 1.733 1.733 0 0 1-1.73-1.711zm9.565 4.968a5.573 5.573 0 0 1-4.081 1.272h-.032a5.576 5.576 0 0 1-4.087-1.272.6.6 0 0 1 .844-.854 4.5 4.5 0 0 0 3.238.927h.032a4.5 4.5 0 0 0 3.237-.927.6.6 0 1 1 .844.854zm-.331-3.256a1.726 1.726 0 1 1 1.709-1.712 1.717 1.717 0 0 1-1.712 1.712z" fill="#fff" /></svg></span></a><a class="heateor_sss_button_print" onclick="window.print()" title="Print" rel="nofollow noopener" style="font-size:32px!important;box-shadow:none;display:inline-block;vertical-align:middle"><span class="heateor_sss_svg heateor_sss_s__default heateor_sss_s_print" style="background-color:#fd6500;width:35px;height:35px;border-radius:5px;display:inline-block;opacity:1;float:left;font-size:32px;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box"><svg style="display:block;" focusable="false" aria-hidden="true" xmlns="http://www.w3.org/2000/svg" width="100%" height="100%" viewBox="0 0 32 32"><path fill="#fff" stroke="#fff" stroke-width=".1" d="M4.467 14.305h23.065v6.498H4.467v-6.498z" /><path fill="#DCDCDC" stroke="#fff" stroke-width=".1" d="M5.228 12.83H26.77l.745 1.39H4.485l.743-1.39z" /><path d="M9.19 8.118h13.467v6.106H9.19z" /><path fill="#fff" stroke="#fff" stroke-width=".1" d="M9.844 6.516h12.312v7.31H9.844z" /><path stroke="#fff" stroke-width=".1" d="M8.602 17.37h14.574v3.396H8.602z" /><path fill="#fff" stroke="#fff" stroke-width=".1" d="M10.152 17.97h11.27l2.233 7.515H7.92l2.232-7.514z" /></svg></span></a><a class="heateor_sss_more" title="More" rel="nofollow noopener" style="font-size: 32px!important;border:0;box-shadow:none;display:inline-block!important;font-size:16px;padding:0 4px;vertical-align: middle;display:inline;" href="https://tribhssn.triblive.com/upper-st-clair-girls-golf-coach-living-american-dream-after-immigrating-from-philippines/" onclick="event.preventDefault()"><span class="heateor_sss_svg" style="background-color:#ee8e2d;width:35px;height:35px;border-radius:5px;display:inline-block!important;opacity:1;float:left;font-size:32px!important;box-shadow:none;display:inline-block;font-size:16px;padding:0 4px;vertical-align:middle;display:inline;background-repeat:repeat;overflow:hidden;padding:0;cursor:pointer;box-sizing:content-box;" onclick="heateorSssMoreSharingPopup(this, 'https://tribhssn.triblive.com/upper-st-clair-girls-golf-coach-living-american-dream-after-immigrating-from-philippines/', 'Upper%20St.%20Clair%20girls%20golf%20coach%20living%20American%20dream%20after%20immigrating%20from%20Philippines', '' )"><svg xmlns="http://www.w3.org/2000/svg" style="display:block;" width="100%" height="100%" viewBox="-4 -4 38 38"><circle cx="10" cy="15" r="3" fill="#fff"></circle><circle cx="20" cy="10" r="3" fill="#fff"></circle><circle cx="20" cy="20" r="3" fill="#fff"></circle><path d="M 10 15 L 20 10 m 0 10 L 10 15" class="heateor_sss_svg_stroke heateor_sss_no_fill" stroke-width="2" stroke="#fff"></path></svg></span></a></div><div class="heateorSssClear"></div></div><p>
Tags: <a href="https://tribhssn.triblive.com/tag/upper-st-clair/" rel="tag">Upper St. Clair</a>
<div style="width:100%;">
<h3>More Golf</h3>
&bull; <a href="https://tribhssn.triblive.com/franklin-regional-girls-golfers-sit-atop-section-3-again/">Franklin Regional girls golfers sit atop Section 3 again</a><br />
&bull; <a href="https://tribhssn.triblive.com/greensburg-central-catholics-aigner-captures-wcca-girls-golf-title/">Greensburg Central Catholic&#8217;s Aigner captures WCCA girls golf title</a><br />
&bull; <a href="https://tribhssn.triblive.com/what-to-watch-for-in-wpial-sports-on-sept-8-2022-defending-golf-champs-meet-again/">What to watch for in WPIAL sports on Sept. 8, 2022: Defending golf champs meet again</a><br />
&bull; <a href="https://tribhssn.triblive.com/freeport-boys-golf-off-to-strong-start-against-local-rivals/">Freeport boys golf off to strong start against local rivals</a><br />
&bull; <a href="https://tribhssn.triblive.com/sewickley-academy-golf-team-set-for-another-excellent-season/">Sewickley Academy golf team set for another excellent season</a><br />
</div>

</p>

<div id="meSearchBladeWidget" style=""></div>
<script>
		var showAds = 'yes'; 
		var toggleOption = 'yes';
		var myIP = "35.173.238.138"; 
		var myProductionFlag = ""; 
		var myShowWidgetsFlag = 'Yes'; 
		var myIamPre = '';var meAlphaTopCategory = 'upper-st-clair-girls-golf-coach-living-american-dream-after-immigrating-from-philippines';var meAlphaChildCategory = '';var myPageType = 'story'; myIamPre = 'story'; var meParentCategory = 'upper-st-clair-girls-golf-coach-living-american-dream-after-immigrating-from-philippines'; var meChildCategory = ''; var meGetTheTitle = 'Upper St. Clair girls golf coach living American dream after immigrating from Philippines';var myIam = myIamPre;</script>

<script src="https://tribhssn.triblive.com/wp-content/themes/hssn/assets/functions/scripts/shops.js?ver=2022-09-14pm" async></script>
<script src="https://tribhssn.triblive.com/wp-content/themes/hssn/assets/functions/scripts/shops-test.js?ver=2022-09-14pm" async></script>
<script data-cfasync="false" src="https://tribhssn.triblive.com/wp-content/themes/hssn/assets/modules/mesearch/mesearch-hssn2-min.js?ver=2022-09-14pm"></script><script data-cfasync="false" src="https://search-module.s3.us-east-2.amazonaws.com/pubs/hssn/mesearch-hssn2-min.js?ver=2022-09-14pm"></script>
</div> 
<div data-sj-ignore class="col-md-4 ml-auto sidebar">


<div class="sidebar-inner sidebar-search">
<div id="meSearchBladeWidgetCompact"></div>
</div>

<div class="sidebar-inner sidebar-search">
<form method="get" action="/search/" class="search-area">
<input class="form-control" tabindex="1" placeholder="SEARCH HSSN" style="text-transform:none; width:50%; float:left; margin-right: 10px;" name="search" size="28" maxlength="75" type="text">
<input class="search-now" tabindex="2" value="Search" type="submit" style="width: 40%;">
</form>
</div>

<div class="sidebar-inner">

<div id='div-gpt-ad-1380843670843-3' class="ad">
<script type="text/javascript">
		
           	if (BigBox_ATF_1active > 0){
			
           		googletag.cmd.push(function() { 
				
				googletag.display('div-gpt-ad-1380843670843-3'); });
           	}
     	</script>
</div>
</div>


<div class="sidebar-inner sidebar-podcast hssn-lightgray">
<style>
				ol, ul, dl { list-style-type: none; padding: 0;}
				div#podcastsWrapper span.duration, 
				div#podcastsWrapper span.publish {font-size:11px;font-weight:normal;font-style:italic;}
				div#podcastsWrapper span.duration{display:block;}
				div#podcastsWrapper span.publish {display:none;}		

		</style>
<script src="https://content.jwplatform.com/libraries/gsc5tz35.js"></script>
<script type="text/javascript">
			function doLoadJWPlayer(divId, audioFile, img) {
				var playerInstance = jwplayer(divId);
				playerInstance.setup({file: audioFile, image: img, width: "100%",height: "300", androidhls: true, preload: "none", ga: {}}); 
			}
			</script>
<script src="https://sportstalk.triblive.com/wp-content/plugins/podcast-sftp/inc/javascriptjwplayerdon.php?tags=donrebel&limit=1"></script>
<div id="podcastsWrapper">
<div id="ttmpodcast"><ul><li class="text-center">Loading...</li></ul></div>
</div>
</div>
<div class="sidebar-inner hssn-lightgray sidebar-video video-playlist">
<h3>Recent Videos</h3>
<div id="video-sidebar" class="carousel special slide" data-ride="carousel" data-interval="false">
<div class="carousel-inner" role="listbox">
<div class="carousel-item video active">
<a href="https://tribhssn.triblive.com/Video/video-rebel-yell-podcast-2022-wpial-football-week-3-preview/">
<img width="1280" height="720" class="img-fluid mx-auto d-block wp-post-image" alt="" src="https://content.jwplatform.com/thumbs/JbMJH6Iq-320.jpg"> <i class="fa fa-play-circle-o fa-lg" aria-hidden="true"></i>
<div class="video-title">VIDEO: Rebel Yell Podcast: 2022 WPIAL Football Week 3 Preview</div>
</a>
</div> <div class="carousel-item video ">
<a href="https://tribhssn.triblive.com/Video/video-rebel-yell-podcast-week-2-team-of-the-week/">
<img width="1280" height="720" class="img-fluid mx-auto d-block wp-post-image" alt="" src="https://content.jwplatform.com/thumbs/hLluazTM-320.jpg"> <i class="fa fa-play-circle-o fa-lg" aria-hidden="true"></i>
<div class="video-title">VIDEO: Rebel Yell Podcast: Week 2 Team of the Week</div>
</a>
</div> <div class="carousel-item video ">
<a href="https://tribhssn.triblive.com/Video/video-rebel-yell-podcast-week-2-recap/">
<img width="1280" height="720" class="img-fluid mx-auto d-block wp-post-image" alt="" src="https://content.jwplatform.com/thumbs/JoW0m1aO-320.jpg"> <i class="fa fa-play-circle-o fa-lg" aria-hidden="true"></i>
<div class="video-title">VIDEO: Rebel Yell Podcast: Week 2 Recap</div>
</a>
</div> <div class="carousel-item video ">
<a href="https://tribhssn.triblive.com/Video/video-rebel-yell-podcast-week-2-player-of-the-week/">
<img width="1280" height="720" class="img-fluid mx-auto d-block wp-post-image" alt="" src="https://content.jwplatform.com/thumbs/Drbdzv0U-320.jpg"> <i class="fa fa-play-circle-o fa-lg" aria-hidden="true"></i>
<div class="video-title">VIDEO: Rebel Yell Podcast: Week 2 Player of the Week</div>
</a>
</div> <div class="carousel-item video ">
<a href="https://tribhssn.triblive.com/Video/video-rebel-yell-podcast-week-1-team-of-the-week/">
<img width="1280" height="720" class="img-fluid mx-auto d-block wp-post-image" alt="" src="https://content.jwplatform.com/thumbs/4tLRwkfI-320.jpg"> <i class="fa fa-play-circle-o fa-lg" aria-hidden="true"></i>
<div class="video-title">VIDEO: Rebel Yell Podcast: Week 1 Team of the Week</div>
</a>
</div> </div>
<div class="video-controls">
<a class="carousel-control-prev" href="#video-sidebar" role="button" data-slide="prev">
<i class="fa fa-chevron-left fa-lg" style="color:white;"></i>
<span class="sr-only">Previous</span>
</a>
<a class="carousel-control-next" href="#video-sidebar" role="button" data-slide="next">
<i class="fa fa-chevron-right fa-lg" style="color:white;"></i>
<span class="sr-only">Next</span>
</a>
</div>
</div> </div>
<div class="sidebar-inner sidebar-facebook">
<h3>Facebook</h3>
<div class="fb-page" data-href="https://www.facebook.com/TribLIVEHSSN/" data-tabs="timeline" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true"><blockquote cite="https://www.facebook.com/TribLIVEHSSN/" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/TribLIVEHSSN/">HSSN</a></blockquote></div>
</div>
<div class="sidebar-inner sidebar-twitter">
<h3>Twitter</h3>
<a class="twitter-timeline" data-width="310" data-height="520" data-link-color="#DD2E44" href="https://twitter.com/TribLiveHSSN?ref_src=twsrc%5Etfw">Tweets by TribLiveHSSN</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>

</div>
<div class="sidebar-inner sidebar-ad">

<div id='div-gpt-ad-1380843670843-18' class="ad">
<script type="text/javascript">
		
           	if (BigBox_BTF_2active > 0){
			
           		googletag.cmd.push(function() { 
				
				googletag.display('div-gpt-ad-1380843670843-18'); });
           	}
     	</script>
</div>
</div>
<div class="sidebar-inner sidebar-civicscience">
<style>
		.civsci-widget {
		padding: 6px 6px 3px !important; }
	</style>
<div id="civsci-id-1399816347" data-civicscience-widget="3cd509cc-abc2-f8f4-e14f-3e8eb04b93f5"></div>
<script type="text/javascript" async src="https://www.civicscience.com/jspoll/4/civicscience-widget.js"></script>
</div>

</div> </div>
</div> 
<footer data-sj-ignore>
<div class="container footerad" id="ad-footer">
<div class="row text-center space">
<div class="col">
<img src="https://www.civicscience.com/idsync?uid=triblive:id" width="0" height="0">

<div id='div-gpt-ad-1380843670843-42' class="ad">
<script type="text/javascript">
		
           	if (Leaderboard_BTF_2active > 0){
			
           		googletag.cmd.push(function() { 
				
				googletag.display('div-gpt-ad-1380843670843-42'); });
           	}
     	</script>
</div>
</div>
</div> 
</div>
<div class="footer-inner">
<div class="container">
<div class="row text-center space social-media">
<div class="col">
<a href="https://www.facebook.com/TribLIVEHSSN/" target="_blank"><i class="fa fa-lg fa-facebook" aria-hidden="true"></i></a>
<a href="https://twitter.com/TribLiveHSSN" target="_blank"><i class="fa fa-lg fa-twitter" aria-hidden="true"></i></a>
<a href="https://www.instagram.com/tribstandout/" target="_blank"><i class="fa fa-lg fa-instagram" aria-hidden="true"></i></a>
<a href="#"><i class="fa fa-lg fa-chevron-circle-up" aria-hidden="true"></i></a>
</div>
</div>
<div class="d-md-none d-lg-none d-xl-none triblive-footer-menu space">
<nav class="navbar navbar navbar-expand-md footer-content-section-inner">
<button class="navbar-toggler" type="button" data-toggle="collapse" aria-expanded="false" aria-label="Toggle navigation" data-target="#navbar-tribbot">
<img src="https://tribhssn.triblive.com/wp-content/themes/hssn/images/TribLIVE_logo-footer1.png" alt="TribLIVE logo footer" class="mx-auto d-block">
</button>
<div id="navbar-tribbot" class="collapse navbar-collapse"><ul id="menu-hssn-trib-menu-1" class="sub-nav list-unstyled"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62073 nav-item"><a href="https://triblive.com/sports/" class="nav-link">Sports</a><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62074 nav-item"><a href="https://triblive.com/news/" class="nav-link">News</a><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62075 nav-item"><a href="https://triblive.com/local/" class="nav-link">Local</a><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62076 nav-item"><a href="https://triblive.com/opinion/" class="nav-link">Opinion</a><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62077 nav-item"><a href="https://triblive.com/aande/" class="nav-link">A&amp;E</a><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62078 nav-item"><a href="https://triblive.com/lifestyles/" class="nav-link">Lifestyles</a><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62079 nav-item"><a href="https://triblive.com/home/video/" class="nav-link">Video</a><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-62080 nav-item"><a href="https://triblive.com/obituaries/" class="nav-link">Obituaries</a></ul></div> </nav>
</div> 
<div class="row text-center space footer-logo">
<div class="col">
<img src="https://assets-tribhssn.triblive.com/2017/12/HSSN_logo_white_600-300x57.png" class="img-fluid" alt="High School Sports Network" style="max-width:250px">
</div>
</div>
<div class="row text-center footer-copy">
<div class="col">
<a class="optanon-toggle-display">Cookie Settings</a>
</div>
</div>
<div class="row text-center footer-copy">
<div class="col">
<ul id="menu-hssn-footer-menu" class="navbar-nav d-flex flex-wrap flex-row justify-content-center sub-nav"><li id="menu-item-62068" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-62068 nav-item"><a href="https://tribhssn.triblive.com/" class="nav-link">Home</a><li id="menu-item-62069" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-62069 nav-item"><a href="https://tribhssn.triblive.com/schools/" class="nav-link">Schools</a><li id="menu-item-62070" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-62070 nav-item"><a href="https://tribhssn.triblive.com/sports/" class="nav-link">Sports</a><li id="menu-item-62071" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-62071 nav-item"><a href="https://tribhssn.triblive.com/recruiting/" class="nav-link">Recruiting</a><li id="menu-item-185806" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-185806 nav-item"><a target="_blank" href="https://signup.triblive.com/trib-hssn-today/" class="nav-link">Newsletter</a><li id="menu-item-238691" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-238691 nav-item"><a href="https://mediakit.triblive.com/triblive-high-school-sports-network/" class="nav-link">Advertise With Us</a></ul>
</div>
</div>
<div class="row text-center footer-copy">
<div class="col">
&copy; 2022 TribLIVE High School Sports Network | All rights reserved
</div>
</div>
</div>
</div>
</footer>
<script src="/wp-content/themes/hssn/js/popper.min.js"></script>
<script src="/wp-content/themes/hssn/js/bootstrap.min.js"></script>

<script>window.twttr = (function(d, s, id) {
		  var js, fjs = d.getElementsByTagName(s)[0],
			t = window.twttr || {};
		  if (d.getElementById(id)) return t;
		  js = d.createElement(s);
		  js.id = id;
		  js.src = "https://platform.twitter.com/widgets.js";
		  fjs.parentNode.insertBefore(js, fjs);

		  t._e = [];
		  t.ready = function(f) {
			t._e.push(f);
		  };

		  return t;
		}(document, "script", "twitter-wjs"));</script>




<div id='div-gpt-ad-1380843670843-99' class="ad">
<script type="text/javascript">
		
           	if (PostIt_2x2active > 0){
			
           		googletag.cmd.push(function() { 
				
				googletag.display('div-gpt-ad-1380843670843-99'); });
           	}
     	</script>
</div>


</script>

<script type='text/javascript' src='https://tribhssn.triblive.com/wp-content/plugins/page-links-to/dist/new-tab.js?ver=3.3.6' id='page-links-to-js'></script>
<script type='text/javascript' id='heateor_sss_sharing_js-js-before'>
function heateorSssLoadEvent(e) {var t=window.onload;if (typeof window.onload!="function") {window.onload=e}else{window.onload=function() {t();e()}}};	var heateorSssSharingAjaxUrl = 'https://tribhssn.triblive.com/wp-admin/admin-ajax.php', heateorSssCloseIconPath = 'https://tribhssn.triblive.com/wp-content/plugins/sassy-social-share/public/../images/close.png', heateorSssPluginIconPath = 'https://tribhssn.triblive.com/wp-content/plugins/sassy-social-share/public/../images/logo.png', heateorSssHorizontalSharingCountEnable = 0, heateorSssVerticalSharingCountEnable = 0, heateorSssSharingOffset = -10; var heateorSssMobileStickySharingEnabled = 1;var heateorSssCopyLinkMessage = "Link copied.";var heateorSssUrlCountFetched = [], heateorSssSharesText = 'Shares', heateorSssShareText = 'Share';function heateorSssPopup(e) {window.open(e,"popUpWindow","height=400,width=600,left=400,top=100,resizable,scrollbars,toolbar=0,personalbar=0,menubar=no,location=no,directories=no,status")}
</script>
<script type='text/javascript' src='https://tribhssn.triblive.com/wp-content/plugins/sassy-social-share/public/js/sassy-social-share-public.js?ver=3.3.42' id='heateor_sss_sharing_js-js'></script>
<script type="text/javascript" src="https://widget.fotomoto.com/stores/script/c16a8e4e6b9367478dd8f225544066096932e993.js?api=true"></script>
<noscript><p>If Javascript is disabled browser, to place orders please visit the page where our <a href="https://www.fotomoto.com/store/c16a8e4e6b9367478dd8f225544066096932e993" rel="external nofollow">photos are available to purchase</a>.</p></noscript>

<script>
			var toolbarID = null;
			var storeID = null;
			function writeLog(content) {
			  document.getElementById("log").innerHTML = document.getElementById("log").innerHTML + content + "<br/>";
			}

			function showToolbar(divid, imgid) {
			  toolbarID = FOTOMOTO.API.showToolbar(divid, imgid);
			}

			function deleteToolbar() {
			  if (toolbarID == null) {
				alert("There is no toolbar.");
				return;
			  }

			  FOTOMOTO.API.deleteToolbar(toolbarID);
			}

			function getStoreID() {
			  var registered_url = "http://www.fotomoto.com/api/samples";
			  FOTOMOTO.API.getStoreID(registered_url, "saveStoreID");
			}

			function saveStoreID(store_id) {
			  storeID = store_id;
			  writeLog("Store ID: " + storeID);
			}

			function getStoreProducts() {
			  if (storeID == null) {
				alert("There is no store ID.");
				return;
			}

			FOTOMOTO.API.getProducts(storeID, "saveStoreProducts");
			}

			function saveStoreProducts(hash) {
			  writeLog("Store Products: " + FMJQ.toJSON(hash));
			}

			function getButtonCaptions() {
			  if (storeID == null) {
				alert("There is no store ID.");
				return;
			}

			FOTOMOTO.API.getCaptions(storeID, "saveButtonCaptions");
			}

			function saveButtonCaptions(hash) {
			  writeLog("Button Captions: " + FMJQ.toJSON(hash));
			}

			function getImageProducts() {
			FOTOMOTO.API.getImageProducts("mainPhoto", "saveImageProducts");
			}

			function saveImageProducts(hash) {
			  writeLog("Image Products: " + FMJQ.toJSON(hash));
			}

			function showPrint() {
			  FOTOMOTO.API.showWindow(FOTOMOTO.API.PRINT, "mainPhoto");
			}

			function showCard() {
			  FOTOMOTO.API.showWindow(FOTOMOTO.API.CARD, "mainPhoto");
			}

			function showDownload() {
			  FOTOMOTO.API.showWindow(FOTOMOTO.API.FILE, "mainPhoto");
			}

			function showEcard() {
			  FOTOMOTO.API.showWindow(FOTOMOTO.API.ECARD, "mainPhoto");
			}

			function checkout() {
			  FOTOMOTO.API.checkout();
			}

			function isBasketEmpty() {
			  if (FOTOMOTO.API.isBasketEmpty()) alert("Basket is empty.");
			  else alert("Baseket is not empty.");
			}

			function showMenu(anchor, menu_type) {
			  FOTOMOTO.API.showMenu(anchor, "mainPhoto", menu_type);
			}
		</script>
</body>
</html>
